Install mantid, mantidqt, or mantidworkbench using conda

Supported platforms:

You need to have Conda, via either miniconda, mambaforge, or miniforge. You can easily check by typing conda --help in the terminal. We recommend using mambaforge. It adds support for conda-forge channels by default, comes with mamba pre-installed (replace conda with mamba in commands to use it), which is a faster version of Conda for creating conda environments, and it doesn't include the channels with license restrictions by default.

The default channels on miniconda come with license agreements which you may need to be aware of.

If not using mambaforge, add conda-forge to your channels:

$ conda config --add channels conda-forge

Installing latest release version of mantid:

$ conda install mantid -c mantid

To install the nightly build of mantid:

$ conda install mantid -c mantid/label/nightly

To install the nightly build of mantidqt:

$ conda install mantidqt -c mantid/label/nightly

To install the nightly build of mantidworkbench:

$ conda install mantidworkbench -c mantid/label/nightly